Wacom Customer Support page: https://support.wacom.com/

Product Registration:
Please register our products on https://www.wacom.com/register
How do I register my Wacom device?

Drawing software:
If you are not able to register, please use the trial version of the software below and try to register again at a later date.
Wacom Drivers:
March 2018: New driver released for Windows (6.3.33-3) and Mac (6.3.33-5). Download drivers and release notes here: http://www.wacom.com/support/product-support/drivers

Touch not working correctly after Driver 6.3.33-5 update for Mac:
http://forum.wacom.eu/viewtopic.php?f=11&t=2581

Mac OS 10.14 Mojave:
Upgrading to Mac OS 10.14 Mojave? A new Mac OSX security feature requires some additional changes to run the Wacom Driver correctly. Please see the instructions found on our support page here. Also, If you have any issues, please try a clean driver install. Follow the steps here.

Search found 3 matches

by JohnnyTwoThumbs
Tue 27. Mar 2018, 01:00
Forum: Pen Tablets
Topic: Adobe software keeps adding itself to Applications in System Prefs
Replies: 2
Views: 700

Re: Adobe software keeps adding itself to Applications in System Prefs

This has been driving me bananas.

Any "feature" this intrusive should have a checkbox to turn it off.
by JohnnyTwoThumbs
Mon 19. Mar 2018, 04:36
Forum: Pen Tablets
Topic: Wacom Setup Wizard opens every time I turn on my tablet
Replies: 20
Views: 5765

Re: Wacom Setup Wizard opens every time I turn on my tablet

Wacom driver updated to 6.3.29-6 and now the issue has gone away
by JohnnyTwoThumbs
Tue 13. Mar 2018, 22:50
Forum: Pen Tablets
Topic: Wacom Setup Wizard opens every time I turn on my tablet
Replies: 20
Views: 5765

Re: Wacom Setup Wizard opens every time I turn on my tablet

Im having the same issue. Every time I start up my Mac, Wacom Desktop Center and the setup wizard open themselves. AutoStart is OFF in the Wacom Desktop Centre menu I have completed the setup wizard at least half a dozen times Mac OS 10.12.6 Wacom Intuos Pro L Driver 6.3.28-2 I'm only using one tabl...

Go to advanced search