Page 1 of 1

MSP Unable to right-click using the pen?

Posted: Mon 19. Feb 2018, 13:19
by tomatogoatee
Alright, I'm really starting to get frustrated at this point. In Photoshop, Artrage, CSP, or Windows Explorer the right-click function works exactly as you would expect it. You get a context menu! However in Chrome, Firefox, Edge, or even IE, the right click simply does not work. On top of that, it freezes the normal left click you would get from just tapping the screen. I have to turn on my BT mouse just to regain control of the cursor.

I'm using Driver version 6.3.27-2 and I also just updated the pen firmware this morning thinking MAYBE one of those might have been the issue.

The touch input right-click also doesn't seem to work as expected in web browsers, either. If I long-press in a blank area or on highlighted text, I get the usual context menu. If I long-press on a link (to open in a new tab, for example) it simply registers as a single click, despite the little box appearing that signals a right-click. (Of course, the touch input might not be related to the pen issues I'm having.)

Re: MSP Unable to right-click using the pen?

Posted: Mon 26. Feb 2018, 15:41
by wacom1
Can you try to turn off 'use Windows Ink' in the driver and test again ? Some Windows Ink functions have been changed with the Windows Fall Creators Update.

Re: MSP Unable to right-click using the pen?

Posted: Fri 2. Mar 2018, 09:30
by Bilboudo
If it could help, I had the same problem and for so I was forced to use a previous driver version (I found that worked fine the 6.3.24-5).

But with the last driver (6.3.28-3) solved this problem and now everything works fine. No more freezes by right clicking in browsers!
And so finally I can use those wonderful on screen commands with 28 slot grid. :-)