Wacom Customer Support page: https://support.wacom.com/

Wacom Product Resources - Drivers, Manuals, Warranty Information & Others

Product Registration:
Please register our products on https://www.wacom.com/register
How do I register my Wacom device?

About ARM architecture-based computer support:
Check our FAQ: Does the Wacom driver support ARM architecture-based computers?

Constant need to calibrate and settings that reset

Cintiq Companion, Cintiq Companion Hybrid, Cintiq Companion 2 and MobileStudio Pro
Posts: 8
Joined: Fri 21. Apr 2017, 06:49

Constant need to calibrate and settings that reset

Postby Cloda07 » Fri 4. May 2018, 06:29

I'm reworking this from what I posted yesterday in reply to a similar topic under the Pen Displays section of the forum.

My wife is on a Macbook Pro on macOS High Sierra with a Wacom Cintiq Companion Hybrid. I have been trying the whole day without any luck to solve this problem. This has been an issue for quite a couple of weeks so I can't say when exactly it started, but my wife has been too busy with projects up until now for me to try and sort it out. She was using driver version 6.3.24-1 as the newer drivers give her too much instability in the main app she uses, Clip Studio Paint. The apps that are mostly used are Clip Studio Paint and Adobe Illustrator and from time to time Paintstorm Studio, Mischief and Autodesk SketcBook Pro.

Each time the Mac reboots and you bring the pen close to the Wacom, it asks you to calibrate. Irrespective if you calibrate it again or not, all settings are lost and you have to set them again. Similar also happens if the Mac sleeps for a while but when I wake it up, it doesn't pick the pen up at all, then I have to unplug the cable from Wacom and plug it back in for it to recognise it again. That would have been OK, but unfortunately I have to then redo the calibration and settings again.

I have also tried all the different ways of backing up the settings and restoring it, but restoring doesn't actually restore the settings. After restoring, before bringing the pen close to the Wacom it doesn't show the pen settings in the Wacom Tablet Preference Pane under System Preferences. As soon as I bring the pen close, it asks me to calibrate it and then only does it show up in the Preference Pane but the settings are not restored.

I am able to disable the Wacom Desktop Centre from loading automatically, but it doesn't make any difference in having to calibrate or saving the settings. I have tried the last five versions of the driver from 6.3.24-1 to 6.3.29-6, completely uninstalling the previous driver and rebooting before installing the new driver.

Please advice me as to what else I can try as it is very frustrating and unproductive to work like this and I can't afford to really spend more time on trying to sort this out.

FYI - Playing around, I randomly figured out a sort of workaround that seems to work but not always reliably so. When rebooting the computer or waking it up from sleep, before bringing the pen close to the screen, unplug only the usb plug from the Mac (up until now I unplugged the cable from the Wacom) and plug it back in. For some or other reason it then just work with your saved settings and without you having to calibrate. If this doesn't work, there is still some hope, you can then unplug the USB and open and use the Wacom Tablet Utility to restore previous settings that you saved. When you plug the USB back in, the pen will hopefully work without having to calibrate and your settings will be restored.

Posts: 8
Joined: Fri 21. Apr 2017, 06:49

Re: Constant need to calibrate and settings that reset

Postby Cloda07 » Mon 4. Jun 2018, 12:21

I downloaded the new drivers (31 May 2018) with the hope that all will be fixed. Unfortunately it is worse and my "tricks" didn't work. I don't have the time to figure it out so I reverted to the previous drivers that I can get to work with the tricks I explained above.

Posts: 897
Joined: Tue 29. Nov 2016, 09:46

Re: Constant need to calibrate and settings that reset

Postby wacom1 » Wed 6. Jun 2018, 09:35

Since this is not the normal or frequent situation, it is not an issue in the list of known or fixed bugs. When you go through calibration once, the information is saved in the driver settings file and you are (normally) never asked again to calibrate - unless you reset settings or use another tablet.

I guess in your case the driver either has trouble to save the calibration data or thinks another tablet is attached. Saving the data may not work if there is an issue with permissions for the settings file and it may not work reliably, if you are using the cloud setting backup. - When you unplug and replug the tablet it can be that the operating system thinks it is a new device and then the driver also reverts to default settings (without calibration). In that case you should normally be able to doubleclick on a local settings pref file to restore those settings.

To resolve the issue: create and switch to new admin account, then uninstall & install the driver in that account - that should help if the problem is permissions related. Second, turn off settings backup in the cloud, use a local settings file. Third, if possible use a USB 2 port/hub instead of USB3, try another cable for the connection. I would also try with the eraser end of the pen. - If no luck contact Wacom customer support. We may want to check the installation log and other information.

Return to “Pen Computers”