News 20.07.2020:
Dear customer, due to cookie policies we cannot allow embedding pictures from 3rd party sites any more.
In case you want to show our support teams a picture, open a case at
Thanks for your understanding.

Wacom Customer Support page:

Wacom Product Resources - Drivers, Manuals, Warranty Information & Others

Mac OS 10.15 Catalina Support:

About ARM architecture-based computer support:
Check our FAQ: Does the Wacom driver support ARM architecture-based computers?

eStore Shipping
Please note that reduced UPS service might affect your region due to CoVid-19 situation. See updated details for UPS services

Product Registration:
Please register our products on
How do I register my Wacom device?

Cintiq Companion 2 Pen + Touch not working YET AGAIN - has been sent for repair in the past

Cintiq Companion, Cintiq Companion Hybrid, Cintiq Companion 2 and MobileStudio Pro
Posts: 1
Joined: Tue 5. Nov 2019, 01:57

Cintiq Companion 2 Pen + Touch not working YET AGAIN - has been sent for repair in the past

Postby Pinipy » Tue 5. Nov 2019, 02:07

Oh boy do I have a lot to say about this. It's been a wild 3 year journey, but I'm quite frankly out of patience. 3 years of issues. 3 years of wacom emails and phone calls and I am back to square 1 with problems. Below is all the context in as much detail as I can give it and hope that there is someone out there that might know how to help!

I bought my Cintiq Companion 2 in 2016. It was my first display tablet and I was the happiest kid alive after saving up from doing art commissions to buy it. It worked flawlessly for about a year until the middle of 2017 when the touch vanished entirely and the tablet would often not even detect it was a tablet.

Now I'm not just talking "oops I turned off touch!", I'm talking...The entire touch driver vanished. And its not a driver you can download. I'm sure you've heard of other horror stories about the missing HID Compliant Touch driver. Yeah, that one.

So, I did what most people would do and contacted Wacom. They made me pay $1180 and had it sent in to "repair" because it was a "hardware issue" (The tablet cost $2800 brand new and they were charging me nearly HALF of that price to fix it???) Sadly, I was a couple of months out of Warranty and had to pay the full price to repair it.

When it returned to me everything seemed to be working fine! There was a large fingerprint indent in my screen (seriously, it looks like someone just pressed 3 of their fingers into my screen while "replacing" the screen) and the "job reference" email stated that they replaced the entire screen, which I know was a lie because the small peel of the screen protector in the top right corner that was there from the first day I bought the tablet, was there upon receiving it after "repairs", and the screen they supposedly replaced was as dirty as it was when I sent it off for repairs.

Fast forward to the middle of 2018, almost a year after "repairs" and although I'd been chugging along making do without the touch (it would frequently not work and I was still having the same issues, again) the pen stopped being detected by the tablet altogether. It decided that it was, once again, no longer a tablet. "There is no tablet connected".

I happened to be overseas in America and went into the Wacom HQ to complain directly, where they just refereed me to their over the phone support. Unhelpful.

After correspondence with Wacom via email and over the phone for now the 2nd time since buying it, and since repairing it, I was prompted to send it back in for another $1100 (ish) "repair". At that point my repairs would have cost nearly the same amount as the entire tablet brand new, and I still would have the same issues. I chose not to send it in because I'm not made of money.

This leads me to today. I've been working as normal since 2018 with this tablet despite the touch not working at all and the tablet frequently bugging out in multiple ways. Half way through finishing something for a client, the tablet freezes completely and just drops all detection of my pen altogether. I have completely reinstalled the drivers, I have reset the tablet to factory multiple times, and I have scowered the internet for the last 3 years about the issues I have had. I don't even think emailing wacom is going to do anything given the fact they will just ask me for more money to not actually fix my device and I'd probably be back here within a year having the same issues.

So I ask you, is there anything that can be done? I know so many people who have had the exact same issues, and I can link to hundreds of online forums that have never been solved. I've just had so many emails and phone calls with Wacom over the last 3 years about all the issues with my tablet and quite frankly, for a $2800 device I expected better.


Model: Cintiq Companion 2 (2016)

Touch not working at all

"No tablet detected" frequently pops up

Pen frequently does not detect whatsoever (it is not the pen, it is the tablet)

Cannot use the pen as a mouse to browse the internet as it frequently does not work properly and freezes when trying to click, scroll, drag and drop, click links, right click, you name it

Sometimes when waking the tablet or turning it on the screen just stays black and the fan runs in the background and nothing happens (this has happened so frequently and I've often lost work from this happening when I've stood up to grab food)

This has been happening since 2016 nonstop despite it being 'repaired' by wacom for a whopping $1180

Every correspondence over the phone, in person or by email with Wacom results in "give us more money to fix it again"

I have paid a total of $3980 for this device INCLUDING REPAIRS and to this date it STILL does not work as intended!

Posts: 1
Joined: Wed 18. Dec 2019, 12:05

Re: Cintiq Companion 2 Pen + Touch not working YET AGAIN - has been sent for repair in the past

Postby chotio » Wed 18. Dec 2019, 12:15

I have a similar problem.

I have recently bought a second hand CC2 device, and try to install Windows 10. At the begining all the devices in devices managemente was detected, but I couldn't access to Wacom propierties.

I tryed to install Win 8.1, even Win8 OEM (the recovery image) but allways the same "the device is not connected".

Because it is an old device, the cost of the repair would be very expensive, so I decided to open and revise the conectors.

I watched:

And I revise the back low part of the connectors

After that I could use my touch screen, I think that the problem was a heavy hit to the device.

Hope It could help you

Return to “Pen Computers”