Page 1 of 1

macOS Sierra - pressure sensitivity issue

Posted: Tue 20. Dec 2016, 12:30
by Inukinori

I have an issue with the Cintiq 22 HD stylus pressure and my painting softwares (Mischief, Sketchbook Pro 6, and Affinity Photo). I'm using a Mac Book Pro 2011 with macOS Sierra 10.12.2.

I've already read the "jumpy pressure sensitivity" topic, but since I'm working on a mac, I thought that creating a new topic would be more useful.

This morning, I did the Wacom update for the driver (update 6.3.19-6).
Afterwards, I opened the software Mischief to continue a drawing I've started yesterday. But now, when I'm trying to draw a continuous line with less pressure, the pen produces a trembling line, which I didn't have yesterday. It only occurs when I'm trying to work with a gentle pressure, when I'm making a quick line with more pressure, it produces a smooth line.
So, I've tried to change the parameters (I initially used default parameters) and also readjust the calibration of the pen. But nothing changed. I've tried to draw with Sketchbook Pro 6 and Affinity Photo, and it also happened in both softwares.
I've done a quick recording in Mischief to show the results with a few strokes :

I hope we can find a solution soon. Thank you.

Re: macOS Sierra - pressure sensitivity issue

Posted: Tue 20. Dec 2016, 16:48
by ScotSolida
Did you completely remove the old drivers and software before installing the new drivers? I have found that I need to do this recently or things will now work properly on my 27 QHD Touch. Every time Apple releases even a minor update, my Cintiq starts behaving badly. Yet reinstalling drivers and software doesn't help unless I first remove all of the old Wacom drivers and software using the Wacom Tablet Utility app, and then restarting before installing the drivers and software (even th same drivers and software). After another reboot, I can switch on my Cintiq and it will work okay.

I'm running the latest Sierra on a 'trash can' Mac Pro and connecting the Cintiq via HDMI (I had problems recently when using Display Port ).

By the way, I tested pressure just now with Corel Painter (2015), Artrage and Clip Studio Paint, and it seems okay.

Re: macOS Sierra - pressure sensitivity issue

Posted: Tue 20. Dec 2016, 18:16
by Inukinori
I've tried to remove completely all drivers and softwares from Wacom, rebooting, and then reinstalling the drivers with another reboot, but the lines I draw continue to behave like I explained.
I'm connecting my Cintiq with a an adapter thunderbolt to DVI.

Re: macOS Sierra - pressure sensitivity issue

Posted: Thu 22. Dec 2016, 18:41
by Inukinori
So, after a discussion with someone from Wacom support (european), here's the solution he proposed :

First, like ScotSolida explained, completely removing the old drivers and software and then installing the new drivers.

Second, if it doesn't work, removing the old drivers and software, then creating a new admin account in which you will install the new drivers. Then, coming back to first admin account and use the tablet normally.

Unfortunately, both solutions didn't worked for me...

Also, something a bit odd, on, the cintiq driver is version 6.3.15-3 while on ... rt/drivers, the driver is in version 6.3.19-6. I don't know if it has something to do with my issue, but I wanted to point it out.

The only solution I have now is to reinstall El Capitan and wait that the issue will be solved soon.

Re: macOS Sierra - pressure sensitivity issue

Posted: Fri 23. Dec 2016, 17:11
by bielero

I have the same problem when I installed Sierra. I was using El Capitan and everything was fine. I think this issue needs to be solved. Since I am a digital artist, I depend entirely on my Wacom products. Downgrading to El Capitan is just too much hassle and to tell the truth, I don't think I have the confidence nor the technological skills to pull this off. I installed the drivers released on Dec 12 and the problem is not fixed.

When would this issue be resolved?