New drivers posted for Mac and Win, version 6.3.25. Now supporting OSX High Sierra. Windows driver 6.3.25-3 is updated to versiob 6.3.25-5 now to fix an issue with the WL Kit. Download drivers and release notes here: http://www.wacom.com/support/product-support/drivers

Note: All users seeing wavy lines using a Wacom Pro Pen 2 with Wacom MSP, Cintiq/Intuos Pro 13” or 16”, please update the tablet pen firmware to address this issue. The update is now available via the Wacom Desktop Center application on your computer.

For clicking problems with Google Chrome see:
http://www.wacom.com/en-us/support?guid ... ListPage-1

Intuos Pro (2017) DoA

Intuos, Intuos Pro, Bamboo, Graphire, etc.
chris80
Posts: 2
Joined: Sat 16. Sep 2017, 15:19

Intuos Pro (2017) DoA

Postby chris80 » Sat 16. Sep 2017, 15:46

Hi ,
Just to report something which happened to me with a brand new 2017 Intuos Pro tablet.
I returned it to Amazon and expect to get a replacement very quickly, however someone may find this feedback usefull. I tried to find similar cases on Google w/o success (well ... I found some but not on Intuos and maybe not exactly the same so I'm not sure if this is a known issue).
The tablet has been plugged on a USB3 port, it was recognized and some drivers were installed. The start page opened and proposed to download the Wacom Center. Restarted the PC as instructed at the end.
At this stage, I started playing with the tablet.
I found that battery almost empty (1%) which looks Strange as most battery powered stuff I use are received pre-charged from factory. Charging was progressing quite quickly (I saw Something like 33 or 44% in a around 10 minutes which again looks unusual).
I found the pen working fine but the touch features were not working although it seems that it was correctly enabled in the W. Center.
I had to unplug the tablet to get touch working.
The W. Center reported that the general firmware was up to date but the Pen and BT FW needed upgrade.
So I tried to upgrade first the Pen FW but it failed during "programming" (tried several times, including PC restart, changing USB port, ...).
Then I tried to upgrade the BT FW. The process completed successfully in a few minutes but then the tablet stopped working.

I have tried several thinks :
- keep it plugged for a while
- pressing several times the ON button, keeping it pushed for a while
- pressing the Reset switch for 1 sec or for 10-15 sec using a nib as instructed in the FAQ
- ...
No way to bring it back to life :-(
Very disappointed of course (it was a anniversary gift for my daugther).
My opinion is that Something was wrong from the beginning (touch not working, Pen FW updt failed)
I'm affraid to test the new one and if it works fine ... I'll be afraid to update FW.

chris80
Posts: 2
Joined: Sat 16. Sep 2017, 15:19

Re: Intuos Pro (2017) DoA

Postby chris80 » Tue 19. Sep 2017, 12:25

Here is a follow-up on this issue.
Amazon replaced very quickly the unit (shipped on Sunday, received on Monday !).
Unfortunately, problems again (curiously not exactly the same) :
- plugged-in : ok, driver installed
- Wacom s/w installed : ok, seems to work fine (touch works). I noted that the battery was at 0%.
- PC Restart -> "unrecognized USB device" every second. Looks like the tablet was resetting.

Then ... I tried on another PC without any problem. Everything works fine. I noted that curiously the battery went to, let say, around 50% very quickly.

So I suspected some kind of USB power issue (like the battery drawing too much power and causing the tablet to reset), so I kept the tablet plugged on the 2nd PC for a while and then I connected it to the 1st PC ... and it worked fine. I tried each and every features and everything appear to be ok, including the charge of the battery which increases slowly (as slowly as on the other PC).
Note that the 1st PC is an HP Pavilion desktop with USB3 ports (maybe 2 or 3 years old). I'm used to connect external, self powered, HDD on these USB ports.

My assumption is :
- when battery is almost empty, the charging circuitry takes too much power from USB or the electronics cannot start correctly
- it is unknown yet if my desktop's USB ports could be the cause of this

If Wacom is interrested in providing comments / suggestions or asking me to do some tests.


Return to “Pen Tablets”