New drivers posted for Mac and Win, version 6.3.25. Now supporting OSX High Sierra. Windows driver 6.3.25-3 is updated to versiob 6.3.25-5 now to fix an issue with the WL Kit. Download drivers and release notes here:

Note: All users seeing wavy lines using a Wacom Pro Pen 2 with Wacom MSP, Cintiq/Intuos Pro 13” or 16”, please update the tablet pen firmware to address this issue. The update is now available via the Wacom Desktop Center application on your computer.

For clicking problems with Google Chrome see: ... ListPage-1

Wacom Bamboo MTE-450A

Intuos, Intuos Pro, Bamboo, Graphire, etc.
Posts: 1
Joined: Sat 25. Nov 2017, 23:21

Wacom Bamboo MTE-450A

Postby Herooyyy » Sat 25. Nov 2017, 23:27

I recently got a really old wacom tablet "Wacom Bamboo MTE-450A" from a friend. He almost never used it in the past and its condition is like new. On the installation driver's CD is written "Windows 98, XP". Also the tablet is from 2008. So according to the CD the tablet drivers only works with windows XP. I tried to install it anyway and it was kinda working. The thing is the pressure. I was not even touching the tablet with the pen but it was already clicking. There was no way to move the cursor without "clicking" (I wasnt actually clicking with the pen, I was just hovering but it was detecting like I was clicking) but to decrease the sensivite to the minimum. What is wrong? The pen or the drivers that doesnt work on windows 7?
I also download some drivers from wacom website but I don't think they worked with this kind of tablet. I also tried to search on google and youtube but I couldn't even find this product (except 1 or 2 really world reviews). So what is the problem? Pen, Tablet or the drivers?

Posts: 628
Joined: Tue 29. Nov 2016, 09:46

Re: Wacom Bamboo MTE-450A

Postby wacom1 » Sun 26. Nov 2017, 06:22

The first generation Bamboo has a mouse emulation build-in and in this mode works on all operating systems. It should still work properly with the latest Bamboo drivers even under Win10. - If you see the tablet LED reacting without touching the tablet or it is clicking & selecting already before when hovering, there is a problem with the pen - too high pentip pressure. You can try to pull out the nib, wipe it clean and put it back in, sometimes there is dust and the tip isn't moving freely. If that doesn't fix it, you would need another pen.

Return to “Pen Tablets”