Wacom Customer Support page: https://support.wacom.com/

Windows 10 Fall 2018 Update:
Updating to the newest Windows 10 Fall update? Wacom has identified a few issues within the latest update. Pan/Scroll is not working correctly in some applications. Also, Modifier Clicks do not work when assigned to pen buttons or ExpressKeys, see the screenshot below. The Wacom driver team has submitted a bug report with Microsoft for these issues and will continue to work with them until it is fixed. More information can be found here: https://www.wacom.com/en-us/support?gui ... c301868667

Mac OS 10.14 Mojave Driver Update:
Upgrading to Mac OS 10.14 Mojave? A new driver has been released. Check the Wacom Desktop Center for the update notice. However, a new Mac OSX security feature requires some additional changes to run the Wacom Driver correctly. Please see the instructions found on our support page here. Also, If you have any issues, please try a clean driver install. Follow the steps here.

Wacom Drivers:
November 2018: New driver released for Mac (Driver 6.3.31-5) with various bugfixes. Download drivers and release notes here: http://www.wacom.com/support/product-support/drivers

Error Message: "<DNL> Lorem ipsum iunctus tabula haud diutius laboris. Est mortuus. Absentis. Kaput."
Please check: viewtopic.php?f=6&t=1888

Inkspace App Updates: http://forum.wacom.eu/viewtopic.php?f=9&t=1949#p5742

Google Chrome - Clicking issues:
http://www.wacom.com/en-us/support?guid ... ListPage-1

Please register our products on https://www.wacom.com/register
How do I register my Wacom device?:https://www.wacom.com/en-us/support?guideTitle=How-do-I-register-my-Wacom-device%2525253F&guideId=4244ade8-634a-433c-88b4-31d83e63226c

PTH 660 Wacom Intuos Pro not working in windows 7 64bit

Intuos, Intuos Pro, Bamboo, Graphire, etc.
Posts: 1
Joined: Wed 17. Oct 2018, 04:00

PTH 660 Wacom Intuos Pro not working in windows 7 64bit

Postby egozi44 » Wed 17. Oct 2018, 04:12

I recently bought PTH 660 Wacom Intuos Pro and found it not work on my desktop which ran win7 64bit
Little did I knew how wacom scorn their customers....

Connecting the cable never showed any signed the tablet was detected aside charging the device, not beep sound from the OS, not windows update notifications to install any driver, nothing new in the device manger, just nothing (there's also no driver in win update to download)

I of course did tried to install the last wacom's driver that supposed to work with my device but when I press on the wacom app in the control panel it just tell me the device is not connetced (when it is and turn on)

After reading many threads and seeing that MANY people had simialr issues I got the impression that using old drivers may solve the issue, I follow and read most of what was in these threads:

https://www.reddit.com/r/wacom/comments ... 660_wacom/

https://www.drivereasy.com/knowledge/wa ... lem-fixed/

https://www.sevenforums.com/drivers/355 ... rking.html

https://answers.microsoft.com/en-us/win ... eb535b41f4

https://www.reddit.com/r/wacom/comments ... ect_to_pc/


And NOTHING solved my issue and I tried to do it in two machines with win7 64 bit and nothing worked, that tablet was expensive yet it seem like I wasted my money of metal washboard cause Wacom don't seem to care about their customers enough to release fixed driver for years

Can someone tell me what I can do to sovle it or the only option I got is to give the tablet back somehow to the store?

Posts: 160
Joined: Tue 8. Aug 2017, 14:35

Re: PTH 660 Wacom Intuos Pro not working in windows 7 64bit

Postby wacom5 » Wed 17. Oct 2018, 14:51

The Wacom driver does work in Windows 7 64bit but you need to have the latest Windows Updates installed. If you have an older version of the driver installed, you might need to do a clean install: https://www.wacom.com/en-de/support?gui ... -(manually)-and-re-install-the-Wacom-driver-on-Windows-for-a-Pen-Tablet%2C-Pen-Display%2C-or-Pen-Computer%3F&guideId=ce67b2c8-4f6f-47c8-93cd-4c6581992d1c

However, from that you describe, your issue seems to be something else entirely. Please check the hardware connection to your computers. Do you see a white LED turning ON near the Touch Ring when you connect it by USB cable? Have you tried using a different cable? Make sure you connect the tablet directly to the computer and that you use a fully powered USB port.

Return to “Pen Tablets”