Wacom Customer Support page: https://support.wacom.com/

Product Registration:
Please register our products on https://www.wacom.com/register
How do I register my Wacom device?

Drawing software:
If you are not able to register, please use the trial version of the software below and try to register again at a later date.
Wacom Drivers:
March 2018: New driver released for Windows (6.3.33-3) and Mac (6.3.33-5). Download drivers and release notes here: http://www.wacom.com/support/product-support/drivers

Touch not working correctly after Driver 6.3.33-5 update for Mac:
http://forum.wacom.eu/viewtopic.php?f=11&t=2581

Mac OS 10.14 Mojave:
Upgrading to Mac OS 10.14 Mojave? A new Mac OSX security feature requires some additional changes to run the Wacom Driver correctly. Please see the instructions found on our support page here. Also, If you have any issues, please try a clean driver install. Follow the steps here.

European Warehouse Inventory:
The European team will be doing inventory from the 27th to the 29th of March. This means that short delays will repairs, order shipping and refunds will occur. We expect to get back to normal schedule on the 1st of April.

New Intuos CTH 690 - Is it faulty or is it a known issue? Mac 10.12.2

Intuos, Intuos Pro, Bamboo, Graphire, etc.
fropirapec
Posts: 2
Joined: Thu 12. Jan 2017, 04:18

New Intuos CTH 690 - Is it faulty or is it a known issue? Mac 10.12.2

Postby fropirapec » Thu 12. Jan 2017, 04:38

Hi.

I just bought a BRAND NEW Intuos CTH 690 - Medium, Pen & Touch.

I'm using a Macbook Pro running Sierra 10.12.2

I have installed the latest drivers (6.3.20-4), then tried several older drivers too.



THE PROBLEM:

I have an issue when clicking between apps (or even between windows of a single app).

Sometimes a click is just ignored -- i.e. the app I've clicked on doesn't come to the foreground. Sometimes I have to click multiple times (which results in a mistaken double click), or click very slowly. Things like dragging a window around become very difficult.

I can see the click itself is registering fine via "current pressure" in Wacom Tablet System Preferences, but when I click on an app or window, it doesn't come to the foreground consistently.



I can't figure it out. Do I need to return the tablet to the store?

Please help!!!!

Return to “Pen Tablets”