Wacom Customer Support page: https://support.wacom.com/

Pen not working after Mac OSX update June 2019:
http://forum.wacom.eu/viewtopic.php?f=11&t=4011

Why is the cursor on Windows a white dot or crosshairs?
http://forum.wacom.eu/viewtopic.php?f=11&t=4013#p8912

Wacom Drivers:
Latest driver released for Windows (6.3.35-3) and Mac (6.3.35-2). Download drivers and release notes here: http://www.wacom.com/support/product-support/drivers

Mac OS 10.15 Catalina Beta:
https://www.wacom.com/en-us/support?guideId=015-916

Product Registration:
Please register our products on https://www.wacom.com/register
How do I register my Wacom device?

Drawing software:
If you wondering which software to choose, check the trial versions below:

Help desperately needed - Intuos not recognized by computer

Intuos, Intuos Pro, Bamboo, Graphire, etc.
randombeing79
Posts: 3
Joined: Fri 27. Apr 2018, 22:31

Help desperately needed - Intuos not recognized by computer

Postby randombeing79 » Fri 27. Apr 2018, 22:41

Hello, all. I've been wrestling with this for over three hours now, so any help that can be offered is greatly appreciated. I recently reinstalled Windows 10 and am having a ridiculously impossible time getting it to recognize my Intuos tablet (an older model, the PTZ 630). So far, I have tried:

-installing the latest drivers from Wacom
-installing the driver I've been using for the past three or so years
-changing USB ports (a total of three, all in different locations on my PC)
-restarting Wacom Professional Service
-removing Wacom related HID entries in device manager

When I connect the Intuos via USB, I get the usual messages telling me that it's been detected and when I install the drivers, I can use the tablet as a mouse, but that's all I can do. Whenever I attempt to access Wacom Tablet Properties, I get the following message: "Your device is not connected to your computer. If your device is plugged in, try using a different port. If that does not work, please contact Customer Support, and we can help."

I feel like I have tried literally everything at this point, and I really am desperate to get my workspace up and running again. Thanks so much for anybody who can point me in the direction of a fix!

Return to “Pen Tablets”