Please enable Javascript to visit our page. Sorry, our site is only available from a browser which accept Javascript.
Wacom Europe GmbH – Europark Fichtenhain A9 – D-47807 Krefeld – http://www.wacom.eu

Intuos3: Losing settings after logoff

Intuos3: Losing settings after logoff

Postby JanWillem » Thu 6. Sep 2012, 11:42

Hi,

After logging off I loose all settings: active tablet area, button functions in certains apps etc.


I'm a user on a domain, luckily with local admin rights.
OS: w7 32bit, driver version 6.3.3-4 (latest).

This is what I checked and tried:
1:
The settings backup appeared a good solution, but strangely, a restore of the settings doesn't change anything. (Still default settings). Allthough the dialogue says it succeeded! It doesn't work. If I customise settings, then a restore even puts the default settings back!
2:
I have all rights on the profile directory at the network (checked it).
3:
I deleted the driver (preinstalled by my company) and re-installed the latest 6.3.3-4 driver. Didn't change anything.
4:
I searched the registry for specific numbers characterising the active area of the tablet, hoping to find the registry part for the settings (then I could export the settings as a .reg file and read it in at every login). But nothing so.

Questions I have:

- where does Wacom write it's custom settings?
- what can I do to be independant on user-profile?
- and of course: what's going wrong?

Thanks, regards,
Jan van Bergen
JanWillem
 
Posts: 2
Joined: Thu 6. Sep 2012, 09:13

Re: Intuos3: Losing settings after logoff

Postby Wacom » Thu 6. Sep 2012, 14:59

The settings are kept under C:\Users\Username\AppData\Roaming\WTablet in a file called wacom_tablet.dat, which is actually an XML file. If the file is not accessible, the driver reverts to default settings. The same happens, if there is problem in the file like invalid settings or invalid characters. Parts of the settings may also be ignored, if there is a tablet.dat file in SYSTEM32.
User avatar
Wacom
 
Posts: 20950
Joined: Wed 15. Oct 2008, 16:00
Location: Krefeld

Re: Intuos3: Losing settings after logoff

Postby JanWillem » Thu 6. Sep 2012, 17:54

Thank you for this information.This is a step forward...

I'm using a Dutch interface. The 'users' directory is called 'gebruikers'.
(Adding a new directory called 'users' isn't possible because the OS sees it in the background as already existing, called 'gebruikers'. Is there a language error in the driver setup?)

There's no 'WTablet' directory in the roaming directory in the 'users' tree. However I have the 'system32\config\systemprofile\AppData\Roaming' directory and this one contains a Wacom_Tablet.dat file.

I browsed the .dat file and found only the default settings.
Apparently it was created but isn't updated by changing settings.

I'd be very happy if you could update the driver:
i.e.1:
Using an environment variable for the settings directory, like WACOMSETTINGS=path.
i.e.2:
By giving the user the option to choose the settings directory?
(choice: default or custom).

Regards,
Jan van Bergen
JanWillem
 
Posts: 2
Joined: Thu 6. Sep 2012, 09:13

Re: Intuos3: Losing settings after logoff

Postby Wacom » Mon 10. Sep 2012, 08:34

There is a undocumented possibility in the driver for redirecting the path for the settings file. This would affect all users on the system. Please contact support@wacom.eu for this information.
User avatar
Wacom
 
Posts: 20950
Joined: Wed 15. Oct 2008, 16:00
Location: Krefeld


Return to Intuos / Intuos Pro

Wacom Europe GmbH – Europark Fichtenhain A9 – D-47807 Krefeld – http://www.wacom.eu